graphein: Tools Used

1. Tools Used

Linux: SuSE 10.0. All of the references here to OS level will become outdated rapidly. Assuming that things ratchet forward comprehensively, these levels merely indicate the minimum known working (for me) level of a tool. Some of these tools are present in all, or most complete, OS installations. Others, while present in the DVD OS distribution, will need to be installed explicitly.

acroread not tightly integrated; use most current version.

awk version 3.1.4 present in SuSE 10.0

bash version 3.00.16 present in SuSE 10.0

fop version 0.20.5 present in SuSE 10.0

The GIMP not tightly integrated; use most current version.

GNU make version 3.80 present in SuSE 10.0

GraphViz version 2.2 present in SuSE 10.0

gv. not tightly integrated; but use version based at least on (= using) GhostScript 8.

ImageMagick version 6.2.3 present in SuSE 10.0

Inkscape. not tightly integrated; use most current version.

khtml2png (khtml2png2). http://khtml2png.sourceforge.net/

For SuSE 10.0, in ./src/khtml2png.cpp:

 
//#include <kde/dom/html_misc.h> //<-- use this for other distributions 
// DMM 
#include <dom/html_misc.h> //<-- SuSE 10.0 /opt/kde3/include/dom/html_misc.h 

Mozilla not tightly integrated; use most current version, or Firefox.

noweb Not present in SuSE 10.0 http://www.eecs.harvard.edu/nr/noweb/ used noweb version 2.8

Saxon-B version 8.8; from Saxonica; not present in SuSE 10.0

SubVersion version 1.2.3 present in SuSE 10.0

VARKON not present in SuSE 10.0

WebDot version 2.2 present in SuSE 10.0

Xerces-j2 version 2.9.0 from Apache; not present in SuSE 10.0

XML Commons Resolver version 1.1 (not 1.2)

xmllint in libxml2 libxml2 2.6.20 present in SuSE 10.0


Select Resolution: 0 [other resolutions temporarily disabled due to lack of disk space]